Photocopier 2
Incident Report for ICT
Resolved
Part fitted and copier now back to normal
Posted Sep 19, 2018 - 15:12 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 18, 2018 - 10:39 BST
Identified
This copier is currently out of action for all printing and copying. The issue has been identified by Itec and a part is on order from Canon to be fitted as soon as possible
Posted Sep 18, 2018 - 10:38 BST
This incident affected: Common Services (Print and Copy).