Issue with ICT Helpdesk
Incident Report for ICT
Resolved
The issue has now been resolved so any future IT requests can now be emailed to the ICT Helpdesk as normal
Posted Dec 16, 2019 - 10:07 GMT
Identified
There is currently an issue with the ICT Helpdesk this morning as we are unable to see any jobs listed. Therefore if you are in need of IT assistance this morning please email direct to one of us in IT, or call us, until further notice. Hopefully it'll be back up and running shortly
Posted Dec 16, 2019 - 08:51 GMT
This incident affected: Administration systems (IT Helpdesk).