Impero issue
Incident Report for ICT
Resolved
Impero seems to be stable over the weekend and working as expected. Apologies for any inconvenience.
Posted Jan 13, 2025 - 09:58 GMT
Monitoring
Impero should now be available again. It is being monitored for stability.
Posted Jan 10, 2025 - 13:18 GMT
Investigating
There is an issue with the Impero service at present. The cause is being investigated
Posted Jan 10, 2025 - 13:04 GMT
This incident affected: Administration systems (Impero).