The upgrade has completed and tested as far as it can be. If you have any internet related issues, please restart your computer first before logging any issue with the IT Helpdesk. Thanks.
Posted Mar 17, 2026 - 17:59 GMT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 17:45 GMT
Scheduled
From 5.45pm to 6pm there will be a ‘planned’ internet outage and any externally hosted service which relies on internet connectivity will be unavailable.
This is to upgrade the firewall/filter to the latest version which needs doing as soon as possible, so apologies for the short notice. Hopefully the impact is minimal at this time of the day.
Access from home to all our externally hosted services should be unaffected.
Posted Mar 16, 2026 - 12:15 GMT
This scheduled maintenance affected: Administration systems (Admin Helpdesk, Door Access System, Finance Helpdesk, Impero, IT Helpdesk, Maintenance Helpdesk, Telephony) and Common Services (Bromcom, Internet services, Print and Copy, College Website, Parent Evening System, Remote Access System, Central Resources Library, My Documents, Online payments, Audio Visual, Cashless Catering).