PSF Finance software not working
Incident Report for ICT
Resolved
This has been resolved now so the PSF purchasing system should be available again to everybody. But if still having issues with PSF please try a restart in the first instance and then helpdesk it if still can't get in
Posted 5 months ago. Apr 04, 2019 - 09:17 BST
Identified
PSF Finance software currently isn't working for any staff so at the moment no orders can be placed and no orders can be processed. We're aware of the problem and just working to resolve it, hopefully it won't be too long
Posted 5 months ago. Apr 04, 2019 - 08:45 BST
This incident affected: Administration systems (Finance system).