Microsoft Forms is not accessible
Incident Report for ICT
Resolved
Forms should be accessible to all now
Posted May 18, 2020 - 14:14 BST
Identified
It appears that some users nationwide can access Forms, but the vast majority cannot!
Posted May 18, 2020 - 11:05 BST
Update
It appears that students cannot access Forms either. I have emailed all students informing them of this in case any assignments contain forms.
Posted May 18, 2020 - 10:49 BST
Investigating
There seems to be an issue accessing Microsoft Forms in the UK. I am unsure whether any forms that have already been issued are working, but it is a Microsoft issue, so I will update when more is known.
Posted May 18, 2020 - 10:31 BST
This incident affected: Office 365 (Microsoft Forms).