The incoming phone call issue has hopefully been resolved now. The issue was caused by a troubleshooting configuration change regarding the sporadic internet issues. Apologies for the further inconvenience caused.
Posted Jun 16, 2025 - 15:31 BST
Investigating
We are experiencing an issue where incoming phone callers cannot hear staff. Staff can hear the caller and all other connections are fine. This might be a by product of the internet issue troubleshooting. Apologies, and this is being worked on as a high priority.
Posted Jun 16, 2025 - 14:08 BST
This incident affected: Administration systems (Telephony).